Tensile Testing Machine – Common Problems and Solutions

Q:Why does the “Online Failed” message always pop up on the screen after I click “Start Test“, how can I solve it?

A:The online failure indicates that the software is not successfully connected to the machine. The reason for not being able to connect successfully may be the serial line or network cable does not work properly, the computer serial port or network card function does not work properly (network connection, IP address is not set properly), the machine power supply problems, the motherboard serial function or network port problems, and board wiring problems. The solution to the problem is to use the exclusion method. Therefore it is best to prepare a spare good board and a computer system. Especially in the factory, in order to quickly and accurately locate where the problem is.
To deal with the problem, the board is only connected to the power supply, serial line (or network cable) to the computer, other lines are not connected, and then open the software (note that the serial port and network card software to correspond) to see if you can successfully online, if not online, find a normal board, whether you can online successfully. If you can, the problem is on the board, write the problem clearly, you need to send the board to the maintenance department by courier. It should be noted that if only the network cable is plugged in, the display successfully online, but plugged into other terminals, display online failure, may be a short circuit in the wiring, plug in other terminals in turn, troubleshooting which terminals have problems.
If the normal board also can not be online, the problem may be in the power supply or computer and serial lines and network cables. Examine the board’s power supply problems, one is to use a multimeter to measure the power supply (the power supply that is used to power the board 24 volts and 5 volts ) is normal or not. In addition, if there are external keys, use external keys to control the machine to see if the machine can move, if the machine can move, the power supply should be normal. Then the problem may be in the computer or connection line.
Troubleshoot computer or connection line problems. For computer, if it is serial port, go to Device Manager and check if the serial port is normal. If it is a network connection, you need to go to the network settings and check whether the IP address is set correctly. If the settings are normal, you may need to change the serial port cable, or network cable test. For the network interface, you can test it by plugging the network cable directly into the machine without the black adapter cable. It may also be necessary to change the computer. Here focus on several states of the network connection:

1, the network cable is pulled out: as shown below, it means that the computer does not detect the network cable inserted, it may be that the board is not powered on, and the network cable is not plugged in, or the network cable is not normal. If you can, insert the network cable into the external network to see if the network cable can be detected. If the external network can, the online board can not be detected, the problem may be in the board, focusing on troubleshooting adapter cables, power supplies and boards.


2, being identified: as shown in Figure 1 below, the yellow light at the network will always be on, the green light will keep blinking at first, after a few seconds, not blinking, the network on-line into the unidentified network, as shown in Figure 2 below. This may be the IP address is not set correctly, to check the IP address settings. If the green light stops blinking after a period of time, the IP address may not be set correctly.



The correct IP settings are as follows, the first line is set to 192.168.1.100. Here, the number 100 can be set to any number from 2 to 255, the other settings are fixed and unchangeable.



3, being identified: as shown in Figure 1 below, the yellow light at the network will always be on, the green light will keep blinking at first, after a few seconds, the network on-line into the unidentified network, as shown in Figure 2 below. but at this time the green light is always blinking, which indicates that the on-line has been successful, the software and the board is constantly sending data.
The problem of not being able to connect, there are more factors involved, you need to check one by one, you must remain patient. The order of troubleshooting is not fixed, but the principle is to check the places that are easy to troubleshoot first as much as possible. For example, if the network is successfully online, the first thing to check whether the IP address is set correctly, and whether the network light is flashing when online. Under normal circumstances, the network yellow light, green light will always flash.

Q:When I click “Up” or “Down“, the machine running speed does not match the set speed, how to solve?

A: Please remove the “√” before “User parameter setting”->”Control scheme”->”Control parameter”->”Speed closed loop control “If there is no displacement encoder connected or the displacement has not been calibrated, please don’t open the “speed closed loop control”. If it still does not correspond, you need to recalibrate the speed. The method of speed calibration is described in the software manual, calibration instructions. Speed calibration is to be done under professional guidance. Generally, end customers are not allowed to calibrate themselves.

Q:After clicking the “Test” button, the machine just runs for a while or does not feel the machine moving, the test is over, how to solve?

A: This may be caused by the incorrect setting of the conditions for automatic judgment of breakage stop. The method is to switch to the “user parameter setting” interface, find “control scheme”, click the modify button, go to the “test method” interface, check the test method.
 
Check whether the switching condition will break, as in Figure 1, or whether the specimen breakage automatic stop is checked. If the time is greater than or equal to the test item, for example, set 1 minute, see if the test will stop immediately. If it does not, it is caused by the beginning of the fracture judgment value is too small.


Fig. 1



Fig. 2


If either of these is the case, the value of “Start Judgement Ratio” may be set too small, causing the force jitter to be mistakenly judged as a specimen fracture and the test stopped. It is necessary to set the value larger, generally set to about 30% of the maximum force of the specimen fracture.



Of course, it is also possible to modify the test method to check whether it is caused by automatic judgement of breakage, such as using time to control the shutdown, and the test method is modified as shown in Figures 1 and 2 below.



Fig. 1



Fig. 2

Also, a machine that is in a limit position can cause the test to stop right after it starts. There is also the possibility that the machine force is not calibrated correctly, or that the board force module is damaged, which may also cause the test to stop immediately.

Q:When I click “Up” or “Down”, the machine’s running direction does not match the setting, and the direction is reversed, how to solve it?

A:Please modify the setting of “Rise and fall direction reverse” in “Setting”->”Calibration”->”System Setting”, and then click the button “Write calibration data to acquisition card” to write the modified parameters to the acquisition card. and then click “Write Calibration Data to Acquisition Card” to write the modified parameters to the acquisition card.

Q:When I select “Stretch” or “Compress” in the test method, the running direction of the machine doesn’t match the setting and the direction is reversed, how can I solve it?

A:Please modify the setting of “Test Direction Reverse” in “Settings”->”Calibration”->”System Settings”, and then click the button “Write Calibration Data to Acquisition Card” to write the modified parameters to the acquisition card.

Q:During the test, it is found that the force or deformation, displacement is shown as negative value, but the customer needs it to be positive value, how to modify it?

A:This is due to the force, displacement or deformation direction is not set correctly, modify the corresponding direction.
For serial software, switch to “User Parameter Setting” interface, find “Control Programme”, click “Modify” button, enter into “Control Programme” setting interface, and then switch to “Parameter Setting” interface, as shown in the figure below.



For the network port online software, through the menu “Settings” – “System Settings”, to enter the direction setting interface.

Q:After clicking test, the software enters into the test state, but there is no curve display, what is the reason?

A:First of all, you have to make sure whether you are really in the test, 1 test button becomes grey, in addition, whether the experiment time is increasing all the time, if the time is not increasing, it means that you are not in the test. It may be that the test conditions are not set correctly, refer to the method of handling problem 3.
 
If the test was entered normally. Then make sure which curve is not displayed. If the force-deformation curve is not displayed, while force-time and deformation-time are displayed, the force-deformation curve is not displayed due to the deformation or the force being 0 all the time. Then first confirm whether the machine is moving during the test (whether there is any change in displacement), if not, please check whether the encoder wiring or displacement coefficient is correct. If there is displacement and the deformation is always 0, please check whether the following parameter settings in the test standard and the test method are too large, modify them to be small or directly modify them to 0 and test again.



If all three kinds of curves are not displayed, you need to check the following two places in the test method corresponding to the standard: 1. Whether to start drawing curves from the first part, if not, please modify it to start from step 1; 2. Whether to tick the use of pre-tensioning speed, if it is ticked, please remove it and test again.



Q:What’s the problem with the large fluctuation in power values?

A:The force value jumps big, first of all, go to the calibration, confirm the force AD value of the last few bits jump, if it is the last 3-4 bits jump, then it shows that the AD sampling is normal, the value jumps big, it may be caused by the calibration is not normal, please re-calibrate it. In addition, if in calibration, found that hanging weights and not hanging weights AD value is not much difference, then you need to check whether the sensor wiring is correct, or whether the sensor is damaged.
 
If the AD value jumps a lot, the last 4-5 bits or even more bits in the display jumps, it shows that the input AD signal is not normal. Then we have to analyse from two aspects, AD is not normal is caused by interference, or the board itself AD module is not normal. Therefore, first of all, please exclude the impact of interference, please take out the motherboard from the machine, the board is only connected to the power supply, serial port, force sensor, to confirm the number of AD jumps, if it is still jumping a lot, then the problem should be in the board itself, you need to return to us for repair. If this jump is not big, then it shows that the interference is caused by the AD jump, then you need to check whether the earth wire and the sensor shield wire is connected.
 
As a special reminder, some people think that the force has been jumping around and unstable before calibration, so they are worried that the force can’t be calibrated, but this is not the case. The force displayed on the software should be checked whether it is normal or not only after calibration. Before calibration, the main look at the AD value and hanging weight force, do not care about the current software display force. It is important to note whether there is a relatively large change in the AD value, at least a few hundred thousand difference, between the unloaded force and the loaded force. If the loading force and not loaded force, AD value does not change much, only the last 3-4 bits change, may be the wiring is not right, or the sensor is damaged. Please deal with it before calibrating.

Q:What is the reason for not being able to hold the force when setting the force?

A:There are two things that can happen when you can’t hold the force, one is that the force held will overshoot and be much larger than the set value. One is that the force is less than the setting value, and it takes a long time to adjust the setting value. For the former, it is caused by the force is small and the pressurisation speed is too big, please adjust the pressurisation speed. In the latter case, the pressurisation speed is too small, so please increase the pressurisation speed. Pressurisation speed is set by the control parameter 4 in the control parameter of the test standard, as shown in the figure below, the value is 1, indicating that the pressurisation speed is 1% of the maximum speed.
 
      
A reminder: for particularly hard materials, the holding force speed needs to be very small, generally only servo motors can achieve a better holding effect. In addition, you need to check the calibration, whether the machine’s travelling speed is set small enough, the default is 0.1. The minimum speed should be smaller than the speed calculated by the control parameter 4, otherwise the control parameter 4 can not be adjusted to its role.

Q:What is the reason for setting the force to stop, but the test curve shows a maximum force that is less than the set force?

A:The maximum force of the test is smaller than the set force, is due to the shutdown, the data collected by the board is too late to send to the computer, the test stops, in the test method, add 0.1-0.2 seconds pause time, if it is still small, please change the filter coefficient to 1.

Q:What is the reason for setting the force to stop, but the test curve shows a maximum force that exceeds the set force?

A:The maximum force of the test exceeds the set force, it is because the speed is too fast when stopping, the motor will overshoot a little, for very hard materials, the force will overshoot. In the test method, the control parameter 100 is changed to a smaller value, for example 90, which means that deceleration starts at 90 per cent of the setting. The minimum speed of deceleration is controlled by “control parameter 4”. If the deceleration effect is not obvious, please check the “control parameter 4” and reduce it, if the deceleration causes the test to be very slow, you need to adjust it.



Q:There is a curve during the test, but no curve is displayed after the test, what is the reason?

A:After the test is completed, no curve is displayed, which may be due to two reasons, one is that the data is not saved successfully, and the other is that the curve setting from step to step is not correctly displayed in the result. When the data is not saved successfully, the test result display is also blank. If the setting steps are not correct, the test results are displayed, but the results are 0. If the latter case, modify the settings in the results, switch to “Test Results”, enter the test results settings page, switch to the “Other” settings page, as shown in the figure below. Check whether the setting is complete, the default setting is from step 1, generally do not need to modify.



If the data is not saved successfully. First of all, check whether the automatic saving after test completion is ticked. Switch to the interface of “User Parameter Setting”, find “Control Programme”, click “Modify” button, and enter into the interface of “Control Programme”, and then switch to the interface of “Parameter Setting”, check “Automatic Storage after Test Completion”. “Then switch to the “Parameter Settings” interface and check “Auto Save after Test Completion”, if it is ticked, the data may not be saved automatically.



The reasons for not saving successfully, one is that the space of the save location is full, or the disc is write-protected. The save location is set in the control parameters, you can create a new folder in the D disc, save to the D disc to try.



There is also the specimen data, check whether the “test lot number” parameter is a special character, when you click on the auto-save, the test lot number will be used as a file name to save the file of the general points, there are special characters, which will lead to the file saved unsuccessfully.

Q:When I click ‘Output word report’ or ‘Output Excel report’, the report cannot be output, or the output report is incorrect, what is the reason?

A: If you can’t output the report, one is the problem that the report template has been modified, and the other is that you haven’t installed the professional version of office software. You need to check whether it is a template problem, in the result setup – other page, select other templates, see if you can output the report. Or use a normal software, copy it to a different computer and see if the report can be output. If you can, it is a template problem. If not, the problem is that Office software is not installed, or you installed is not the professional version of Office, you need to install the professional version of Office.
If it is a template problem, how to edit the template, see the instructions in the manual – report editing.

Q:What is the reason that the machine does not move when I click the UP and DOWN buttons?

A:The machine does not move, it may be a board problem, or it may be a wiring or motor problem. The way to troubleshoot the board problem is:
Inverter motor: inverter motor is used to control the direction of motor movement by board D0+, D0- and D1+, D1-. OV and AVI are used to control the motor speed.



The method to test whether the motor direction control is normal: unplug the connector connecting the inverter motor on the board, click the up and down buttons, switch the multimeter to diode mode, the positive terminal of the meter head measure the board D0+, the negative terminal of the meter head measure the board D0-. Or test the D1+, D1- ends. Note that the diode is made of positive and negative, the positive and negative of the meter pen must be correct when testing.
 
Under normal circumstances, when stopped, D0+, D0- and D1+, D1- are disconnected. When rising or falling, D0+, D0- or D1+, D1- have a way on, a way off. For details, see the two tables below.
 

 
The method to check whether the motor control speed is normal or not: unplug the connector on the board connecting to the inverter motor, switch the multimeter to the measurement voltage mode, the positive pole of the meter head to measure the board AVI (1), and the negative pole of the meter head to measure the board OV (2), and modify the speed of the machine on the software, and the value of the voltage will change accordingly. For serial boards, the voltage range between OV and AVI is 0 to 5 volts. For networked boards, the voltage range between OV and AVI is 0 to 5 volts. The OV and AVI voltages become larger and smaller as you modify the speed. The greater the speed, the greater the voltage.
 
Servo Motors: The board controls the servo motor speed and direction via Pulse (PUL, pin 4) + Direction (Sign, pin 3) as shown below. You can test the output voltage on the board to confirm whether the board is normal or not.



The method of checking is as follows: unplug the connector on the board connecting to the servo motor, switch the multimeter to test voltage mode, and measure the voltage between pulse PUL and OV, and direction Sign and OV respectively. Under normal circumstances, when stopped, the pulse PUL and OV voltage is about 5V. When pressing up or down, the voltage is about 2.5V. The voltage between direction Sign and OV is 5 volts if rising and 0 volts when pressing down. The reverse is already true, if it is 0 volts on rise, it is 5 volts on fall.
 
If through the above test, if the board is not normal, please express the board to us for repair, if it is normal, please check whether the wiring and motor is normal.

Q:Clicking up or down, the machine is moving but displacement and deflection are not increasing, what is the reason?

A:If the machine is moving, but there is no displacement, indicating that no displacement is detected, the displacement encoder may not be connected, or the wiring is not right.



To measure machine displacement, there are currently three ways, external encoder, servo motor feedback pulse and virtual displacement. For the first two ways, you must wire to the displacement input port of the board. For servo or inverter motors, check whether the displacement input port is wired and wired correctly. For stepper motors, check whether the use of virtual displacement is ticked in the calibration-system settings in the software.

Q:When I press up or down, the machine moves a little and then stops moving, what is the reason?

A:The machine does not move, there are two cases, one is the controller or software shows in action (the button is pressed, did not switch to stop mode), but the motor does not move. Secondly, the controller or software shows that the action has stopped (the button is restored to the stop state), and the machine does not move.
For the first case, it shows that the controller is executing the rising and falling command, but the motor does not move, it should be a problem with the motor, to check whether the motor is alarmed or stuck.
For the second case, the controller stops by itself, the controller will execute the stop command, there are three main cases, the force exceeds the range, the machine limit is abnormal, there is also an external send a stop command (such as key, hand control box). Firstly, check whether the force display is normal, if possible, enter the calibration to see whether the AD value of force is normal. Secondly, check if the limit is abnormal, you can try to unplug the limit. Also check if there is an external button or hand control box, you can unplug these devices to test it.

Q:When I open the software, it says “The trial period has expired, please contact the manufacturer”, what is the reason?

A:When you open the software, it prompts “the trial period has expired, please contact the manufacturer”, it is due to the setting of the trial period, the trial period is up, you need to enter the registration code, re-register to continue the trial, the registration code need to contact the manufacturer to provide.

Q:When I open the software, it says “Cannot locate Labview to run the engine”, what is the reason?

A:The prompt “Cannot locate Labview to run the engine” is because the software driver Driver2012 is not installed. Our TM2101 software can be used directly after copying it to the computer. However, the driver must be installed before, as long as the driver is installed, it can be used all the time. To update the software, just copy the new software to the computer, no need to reinstall the driver.

Q:The motherboard of a previously used instrument broke and we replaced it with a new one. How should I proceed?

A:When you change the motherboard, you need to write the previous calibration data to the new motherboard. Open the software, after online successfully, click the menu “Help”-“Write calibration data to the acquisition card”, write the calibration data from the computer to the acquisition card. Or through the menu “Settings”-Calibration, enter the calibration interface, click “Write calibration data to the acquisition card”, write the calibration data from the computer to the acquisition card.
One copy of calibration data is saved on the motherboard and one copy is saved on the computer, and the calibration data on the board is the one that actually works. So in calibration, the software should press OK to exit, so that the calibration data is saved on the computer, otherwise the calibration data on the computer is still not calibrated data. Sometimes, just after the calibration is done, you enter the calibration data and find that the calibration data is incorrect again, please make sure whether you press OK to exit.

Q:What should I do if I have to change the software of a previously used instrument and the computer of the instrument is faulty or the software of the instrument is corrupted?

A:When you change to a new software, you have to restore the calibration data, test method settings and test result settings, specimen data settings, unit settings and other settings of the original software to the new software. The easiest way to restore is to find the previous backup software and copy it over. So making a good backup is the key.
 
If you want to update from the previous software to the new software, you generally need to copy these files or folders in the software data to the new software:
1. Calibration data, Calibration data, Calibration, but it is best to go into the calibration to read;
2. Test method files: Project and ProjectBackup folders;
3. Test result settings: Result folder
4. Material parameter settings: Material and Material1;
5. Report templates: Excel template catalogue ExcelTemplate and Word template WordTemplate
6. Custom formula file: NewFormula, if there is a new addition to the formula, you need to replace this file
Calibration data must be updated, other data you can open the software to reset.
Remind again, debugging the software, it is best to make a good backup.

Scroll to Top